Slightly pulling to the right?? - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 05-04-2011, 11:20 PM
WRXtuners Member
 
Scooby08's Avatar
 
Join Date: Feb 2010
Location: Connecticut
Posts: 13
Scooby08 is an unknown
Slightly pulling to the right??

Hey guys...I had new tires mounted, an alignment done, etc....everything came out fine....Before I brought it to town fair my car slightly pulled to the right...I figured it was just a alignment issue....Well it seems thats not the case...The print out showed everything was fine and the guys at the shop said nothing was wrong with the suspension but then again they are just a tire place.....before I take it to a local performance shop...any idea's of what I should look for?....at this point in time I think it might be a strut issue...possible passenger side blown or going strut? any signs of this I can check out before some shop decides to push me into upgrading to coilovers and what not...because thats what they like to do out here on the east coast lol...thanks in advance!
Scooby08 is offline  
Sponsored Links
Advertisement
 
#2 Old 05-05-2011, 05:53 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
So the wheels are still stock ? Only saying this because there are many hub centric wheels out there and if you forget the ring.... you know the rest.

Could be just 1 bad tire. Switch the tires around and see if it pulls to the same side.

How many miles are on the car ?

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#3 Old 05-05-2011, 08:55 AM
WRXtuners Member
 
Join Date: May 2006
Location: Virginia
Posts: 2,338
Images: 9
brfatal is a WRX expert worth listening to brfatal is a WRX expert worth listening to brfatal is a WRX expert worth listening to
Garage
Could be your roads.
brfatal is offline  
#4 Old 05-19-2011, 06:48 PM
WRXtuners Member
 
Join Date: Mar 2011
Location: California
Posts: 13
rollnsf is an unknown
I'm having the same issue.

I bought the car used, it was pulling to the right, I had an alignment. I got all the readings and it looked to spec. But the car was still pulling to the right.

The tech today told me this was normal for safety purposes (so if you fall asleep, you don't drift into the oncoming traffic in the left lane, instead you drift to the right). I think this is BS. I'm taking it back to the dealership.
rollnsf is offline  
#5 Old 05-27-2011, 07:32 PM
WRXtuners Member
 
Join Date: May 2011
Location: Indiana
Posts: 2
rocooper45 is an unknown
My 09 did the same thing after switching from winter to summer setup, drifts right even driving left of the crown. And I too had an alignment.

Check tire pressure.

Tire pressues won't come up on the alignment printout. I relieved much of the drift problem with a rebalance of the tire pressure. Also, I think the tire pressure and tire/wheel combos make a difference on how much drift you get.

The TPMS didn't signal a problem. GL
rocooper45 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On