ABS help - Subaru WRX Forum
 3Likes
  • 1 Post By boo-key
  • 2 Post By Fidrat
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 07-17-2014, 12:52 PM Thread Starter
WRXtuners Member
 
303_Scooby's Avatar
 
Join Date: Jun 2014
Location: Colorado
Posts: 13
303_Scooby is an unknown
ABS help

sorry if this isn't this right place to post, but my abs light keeps coming on. Anyone know why this could be happening? it just means that ABS isn't working when the light in on right? not sure lol. Anything will help
303_Scooby is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 07-17-2014, 05:30 PM
WRXtuners Member
 
Join Date: May 2006
Location: Virginia
Posts: 2,373
Images: 9
brfatal is a WRX expert worth listening to brfatal is a WRX expert worth listening to brfatal is a WRX expert worth listening to
Garage
Could be a sensor issue. With a lot more details this is going to have to be diagnosed by someone in person.
brfatal is offline  
post #3 of 9 Old 07-17-2014, 08:51 PM Thread Starter
WRXtuners Member
 
303_Scooby's Avatar
 
Join Date: Jun 2014
Location: Colorado
Posts: 13
303_Scooby is an unknown
Okay thanks gonna check it out and if it keep on coming on im going to have to take it somewhere.

"Life's to short to stay stock!"

2005 Wrx Wagon (Silver)
303_Scooby is offline  
post #4 of 9 Old 07-18-2014, 09:07 AM
Vew
Moderator
 
Vew's Avatar
 
Join Date: Feb 2004
Location: West Virginia
Posts: 3,452
Images: 10
Vew is more helpful than not
Send a message via AIM to Vew
Removed b/c incorrect

I've also seen it come on when a wheel bearing is starting to go bad, but there are usually other symptoms that go along with this.

Jon
"We live for a good time, not a long time."
RIP Colin McRae

Last edited by Vew; 07-23-2014 at 12:56 PM.
Vew is offline  
post #5 of 9 Old 07-18-2014, 12:52 PM Thread Starter
WRXtuners Member
 
303_Scooby's Avatar
 
Join Date: Jun 2014
Location: Colorado
Posts: 13
303_Scooby is an unknown
Okay thanks alot!!!

I just kind of bought the car maybe a couple months ago, and the front driver side wheel bearing had went out. There was sooo much play with the wheel it wasn't funny! So i changed out the wheel bearing but while doing so it was dropped a couple times because i had a hard time pressing it into the hub. The same side is beginning to squeak really bad when ever i turn or am just going 20mph or less. (There are two different sounds. One sounds like the wheel bearing, the other sound like metal on metal)

I think that im just going to try to get it into this shop super repair that specializes in subaru see if they can just take a look and tell me whats wrong. But thanks again pretty sure thats my issue here

"Life's to short to stay stock!"

2005 Wrx Wagon (Silver)
303_Scooby is offline  
post #6 of 9 Old 07-19-2014, 08:16 AM
WRXtuners Member
 
Epictofer's Avatar
 
Join Date: Aug 2013
Location: North Carolina
Posts: 166
Epictofer is known to be trustworthy and helpful Epictofer is known to be trustworthy and helpful Epictofer is known to be trustworthy and helpful
Garage
Brake light comes on with low brake fluid. ABS light on means there is a problem with the abs system and it is turned off.
Epictofer is online now  
post #7 of 9 Old 07-23-2014, 12:54 PM
Vew
Moderator
 
Vew's Avatar
 
Join Date: Feb 2004
Location: West Virginia
Posts: 3,452
Images: 10
Vew is more helpful than not
Send a message via AIM to Vew
Quote:
Originally Posted by Epictofer View Post
Brake light comes on with low brake fluid. ABS light on means there is a problem with the abs system and it is turned off.
Doh, you're correct. My mistake.

Jon
"We live for a good time, not a long time."
RIP Colin McRae
Vew is offline  
post #8 of 9 Old 07-25-2014, 01:27 AM
Premium Member
 
boo-key's Avatar
 
Join Date: Dec 2008
Location: Tennessee
Posts: 1,259
Images: 6
boo-key is known to be trustworthy and helpful boo-key is known to be trustworthy and helpful boo-key is known to be trustworthy and helpful
Garage
Quote:
Originally Posted by 303_Scooby View Post
The same side is beginning to squeak really bad when ever i turn or am just going 20mph or less. (There are two different sounds. One sounds like the wheel bearing, the other sound like metal on metal)
Did the wheel bearing come already greased or if not did you pack it? That could be the metel on metal sound your hearing

As far as ABS goes,there are few components to it so, troubleshooting is not bad. There is a tooth wheel on the hub. this has lots of ridges or teeth that the sensor reads magneticly. The sensor is nothing more than a magnet that reads the pulses in the ridges. If the light is on the ABS will be disabled. Most common problems in order are as follows.

Broken wire on sensor
Unplugged or bad connection on sensor
Broken wire or bad connection after sensor
dirty sensor
broken or dirty tooth wheel
bad ABS ECU (I know busses have these but don't think cars do)
303_Scooby likes this.

Adair
06' wrx tr
Phatbotti tuned!
boo-key is offline  
post #9 of 9 Old 07-26-2014, 05:31 AM
WRXtuners Member
 
Fidrat's Avatar
 
Join Date: Apr 2003
Location: Iowa
Posts: 649
Images: 1
Fidrat is more helpful than not
Quote:
Originally Posted by boo-key bear View Post
Did the wheel bearing come already greased or if not did you pack it? That could be the metel on metal sound your hearing

As far as ABS goes,there are few components to it so, troubleshooting is not bad. There is a tooth wheel on the hub. this has lots of ridges or teeth that the sensor reads magneticly. The sensor is nothing more than a magnet that reads the pulses in the ridges. If the light is on the ABS will be disabled. Most common problems in order are as follows.

Broken wire on sensor
Unplugged or bad connection on sensor
Broken wire or bad connection after sensor
dirty sensor
broken or dirty tooth wheel
bad ABS ECU (I know busses have these but don't think cars do)
Not only do we HAVE an ABS/ECU some if them were calibrated wrong from the factory. Check out this thread. I copied a TSB word for word in post #7 ABS ECU recalibration I think this is only for the bugeye.
boo-key and 303_Scooby like this.

All right, where is the distributor cap? I need to find the #1 plug wire to hook up my SUN machine.
Fidrat is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On