Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Bolt-on Tech (EJ255/EJ257 2.5L 2008+ WRX, STi, and GT) (http://www.wrxtuners.com/forums/f121/)
-   -   Turbo noise lessons learned (http://www.wrxtuners.com/forums/f121/turbo-noise-lessons-learned-35290/)

Brockton 06-01-2013 04:08 PM

Turbo noise lessons learned
 
Hopefully sharing this story will help someone else on here:

So I have a TP stage 2 tune at 18.5 psi on my 08 wrx. I hit full boost in third and suddenly i heard this god aweful screeching noise. My first thought is that it was the tranny, I had accidently went into third instead of fifth a few minutes before it happened. I took it into the subaru dealership, I know the tech there and he's done a lot of performance builds on the local STI's and WRX's in the area, and is very reputable. He got in the car, heard it, said it was a blown turbo.

This made sense to me after hearing similar sounds from youtube from blown turbos. and I would only hit 5psi before the screeching noise and it wouldn't create any more boost than that 5psi. So went to nasioc and got a used turbo, no shaft play, ect..., did the swap myself... Huge PITA, a lot harder than it seems, especially getting the return line on the bottom lined up and getting the intake inlet tube lined up at the same time, it takes a lot of patience.

After all that work, got in the car, started it up, same exact thing, hit 17psi, noise happened, then no more than 5 psi. After inspecting the old turbo and this last little event it got me thinking. The old turbo was perfect, blades in great shape, no shaft play. So I followed my hunch that it was leak, the more i listened to it the more it sounded like air going out of a balloon when you pull the mouth of it tight, that high pitched whining noise.

Went to a local performance shop, (EPT Performance, awesome dudes there if you're in the el paso area) and got a boost leak test done. Sure enough it was a leak. The hose going into the throttle body was leaking on the throttle body side. It was leaking previously from the TMIC side, making a loud wooosh sound under boost, took the annoying little rubber boot off of the hose and tightened the clamp back down and it was fixed.

So the moral of this story is, before you waste money and time on a possible solution, make sure you investigate the problem fully, and don't just take an "expert"'s word on it. The reason I wrote this up is because I couldn't find many people with this problem when I was researching it. I wasted $250 and about 7 hours of work on something that had nothing to do with the problem. Lessons learned the hard way.

boo-key bear 06-01-2013 04:28 PM

Now you can send your old tubo off to grimmspeed for some PnP and coating with no downtime and sell your old one. If you look at it like that its not a total loss. Sorry you bought one when you didnt need it but, glad you got it fixed!

06_hawk_eye 06-01-2013 04:29 PM

Yeah I'm actually looking for a turbo. Gonna send it to blouch and get it rebuilt with a 19t compressor and p and p. so of you don't want your old turbo ill buy it


[color=gray]Sent from [url=http://www.autoguide.com/mobile]AutoGuide.com App[/url][/color]

Brockton 06-01-2013 05:17 PM

it wont fit a hawkeye, 08+ have the LGT style flange for the tmic, made it really annoying to find a replacement

sleepr 06-01-2013 07:47 PM

Ladies and Gentlemen,

Support your local independent (Subaru) mechanic, you won't be disappointed! ;)


OP, happy to hear your situation turned out well!


All times are GMT -5. The time now is 03:25 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.