Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Bolt-on Tech (EJ255/EJ257 2.5L 2008+ WRX, STi, and GT) (http://www.wrxtuners.com/forums/f121/)
-   -   Loud Screech New Recirc Valve (http://www.wrxtuners.com/forums/f121/loud-screech-new-recirc-valve-30898/)

cwinterbower 06-16-2011 03:50 PM

Loud Screech New Recirc Valve
 
Just wondering if anyone has come across this issue, it's a little hard to diagnose when I am driving. It doesn't sound like turbo stutter, though I guess it could be. I just put a new recirc valve on (moving from vta), and adjusted it to where it barely breathes at idle, and releases perfectly fine at part throttle with zero stutter at low boost, however when I really wind it up 20lbish, I get a loud almost un nerving squelch. Not really sure how else to describe it, I used bending radiator hose for the return (has a spring inside), and it returns to a Perrin turbo inlet. I am wondering if the sound I am hearing is the pressure making it's way through the tube? Or possibly hitting the turbo on the intake side?(the pressure). I have checked the obvious signs, kinks in the recirc line etc, but the path to the turbo inlet from my bov is a fairly bendy one.
Again just hoping someone may have stumbled across a similar issue.
Thanks.
-Carl

mfarnham 06-16-2011 05:04 PM

Do you have a gasket between the recirc valve and the intercooler?

cwinterbower 06-16-2011 05:16 PM

Yeah, it sits on the pipe from the front mount. It's a new gasket and sealer. There is a point where the actual valve has a screw in peice that mounts to the recirc hose that is just "hand tight" as I don't want to put anything abrasive on the aluminum. But the sound is coming from the passenger side of the car, (the inlet or turbo). It doesn't make the chh chh chh chh like turbo stutter, its just one loud bark. The recirc hose makes a very tight bend right before it gets to the inlet, though it is open and I tested it. Just can't figure out what the sound is.
-Carl

mfarnham 06-16-2011 06:13 PM

Sorry I didn't realize you had a front mount. If you are hearing the sound after putting on a recirc valve, instead of VTA, then it is probably the hose going to the inlet. Maybe the bends are just too extreme.


All times are GMT -5. The time now is 08:52 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.