Fuel pump install issues. - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 06-16-2010, 04:10 PM Thread Starter
WRXtuners Member
 
Join Date: Apr 2009
Location: Ontario, Canada
Posts: 46
operadude is more helpful than not
Fuel pump install issues.

Just installed a Walbro 255 Fuel pump and VF52 with XPT stage 3 map for my wife's 08WRX.
Couple of things I wanted to confirm.
I am finding I have to put the ignition to the on position for 2 to 5 seconds and wait until I hear the pump finish pumping the fuel before cranking the engine over or it will hesitate to start. It is not instant like OEM. Is this normal?
Secondly, when I installed the fuel pump one of the rubber O rings I transferred from the old pump to the new one was a little loose. Is this normal? We thought it might compromise pressure so I installed a new O ring we found in the shop. The problem there is the rubber O ring we replaced it with may not be made to last in a fuel tank. It seemed similar enough though. Hopefully it's ok. Did any one else have the same issue with one of the rubber O rings? If this is normal I will go back in and replace the new one I installed with the original. If not, I will order one that's made for the pump so my wife doesn't find find herself stranded on the highway any time soon.

Fabio
2008 VF52 WRX Opensource Magnus Motorsports Stage 3 Tune
operadude is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 06-16-2010, 05:42 PM
WRXtuners Member
 
synolimit's Avatar
 
Join Date: Aug 2009
Location: Ohio
Posts: 1,415
synolimit is a helpful contributing member
i didnt have a problem with the OEM but ive heard lots of people do. you need a Valcom 002 or 202 or something (search here How To: Walbro 255lph Pump for 2008 STi/WRX/LGT - Subaru Impreza WRX STI Forums: IWSTI.com). please dont quote me on that but its an oring that can with stand fuel and the number is the size. people either just replace it or they double them up. read up though.

you should have no problems if you got a real Walbro 255! mine runs and sounds just like stock. ebay chinese ones are knock offs.

Scott-2011 WRX 335HP 394TQ 93 VF52!
http://www.wrxtuners.com/forums/f121/2011-wrx-build-31226/
synolimit is offline  
post #3 of 7 Old 06-16-2010, 10:29 PM
WRXtuners Member
 
Join Date: Apr 2010
Location: Pennsylvania
Posts: 26
rollertoaster is more helpful than not
what's the deal with the ebay walbro's being knockoffs? That worries me as, that's where I got mine from. It definitely had the walbro emblem stamped on it, but it is noisey.

OP, It sounds to me like the o-ring you replaced is leaking. makes sure to read the instructions that synolimit linked to. And make sure you skim through all the pages of the thread, there is more useful info that is not on the first page.
rollertoaster is offline  
post #4 of 7 Old 06-17-2010, 06:23 PM
WRXtuners Member
 
Join Date: Sep 2009
Location: New Jersey
Posts: 17
sexysilvrwrx is an unknown
where did you get that VF52? what kind of price were you looking at as I am currently looking for one myself if I dont go bigger and change a ton of stuff.
Thanks
sexysilvrwrx is offline  
post #5 of 7 Old 06-18-2010, 10:50 AM Thread Starter
WRXtuners Member
 
Join Date: Apr 2009
Location: Ontario, Canada
Posts: 46
operadude is more helpful than not
Quote:
Originally Posted by sexysilvrwrx View Post
where did you get that VF52? what kind of price were you looking at as I am currently looking for one myself if I dont go bigger and change a ton of stuff.
Thanks
I bought the VF52 from a Subaru dealership. I told them how much cheaper it was to order it on line and they knocked off some money to make it comparably priced.
It was an impulse buy. I initially only wanted to inquire about the price out of curiosity as I originally was intending to buy either the AVO 380 or 450. I got suckered in. I liked the fact that I could just take it home and not worry about my wife getting the courier package before me.......
If you look online, the going rate right now is between $930 to $1100 USD.

Fabio
2008 VF52 WRX Opensource Magnus Motorsports Stage 3 Tune
operadude is offline  
post #6 of 7 Old 08-27-2010, 01:50 PM
WRXtuners Member
 
Join Date: Feb 2010
Location: Virginia
Posts: 82
LewdWRX is an unknown
Operadude,

What did you find to correct the hard starting issue?

Out of curiosity, did you have a slight bulg in the bottom of your fuel pump assembly once the Walbro was in?
LewdWRX is offline  
post #7 of 7 Old 08-30-2010, 03:40 AM Thread Starter
WRXtuners Member
 
Join Date: Apr 2009
Location: Ontario, Canada
Posts: 46
operadude is more helpful than not
Quote:
Originally Posted by LewdWRX View Post
Operadude,

What did you find to correct the hard starting issue?

Out of curiosity, did you have a slight bulg in the bottom of your fuel pump assembly once the Walbro was in?
The issue fixed itself. The issue went away on it's own after a week. There may have been a kink in the line that unkinked itself or perhaps the pum needed to be worked in. Everything looked normal in there when we double checked to make sure. I since put it on the dyno and there was no shortage of fuel being pumped at that time and neither have I found any warning signs on any of my logs with Romraider. Weird but I will take that.

Fabio
2008 VF52 WRX Opensource Magnus Motorsports Stage 3 Tune
operadude is offline  
Reply


Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On