Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Bolt-on Tech (EJ255/EJ257 2.5L 2008+ WRX, STi, and GT) (http://www.wrxtuners.com/forums/f121/)
-   -   Forge BPV Awareness (http://www.wrxtuners.com/forums/f121/forge-bpv-awareness-42210/)

arewmors 12-07-2013 05:22 AM

Forge BPV Awareness
 
4 Attachment(s)
So I am not writing this to bash anyone or Forge. I understand that not everything can be perfect when being manufactured, I was one of the unfortunate unlucky ones. I am writing this as an informative thread to other members that may have boost leaks, and/or to inspect the product when you receive it as best you can.

I've had the Forge BPV for a few months now. Occasionally I would hear the screeching sound you get when you pinch the end of the balloon and let the air out. I first had swapped the IC to TB hose out because that had leaked once before. Which it was probably one of the factors because the end of the stock hose had a crimp in it. I replaced that with a silicone hose. Occasionally still hearing the leak. So I took it to my local performance shop who did a boost leak test and immediately found the issue. The leak was coming from the BPV at the base of the cylinder where it connects to the flange. I took the car home pulled it off and put the stock BPV on until I get a new one. I have posted some pictures of the BPV and what I found to be the problem. After I got the BPV off I closely looked at where it was leaking and there is actually a gap where the two parts meet. So it was leaking the entire time, I may not have heard it every time because the gap was big enough where the air could pretty freely flow out. Other times I think the air pinched the o-ring in it to cause the screech because the gap was made smaller. Mind you I have never taken it apart from where it was leaking either and it was leaking from the day I put it on, so it wasn't user error.

Hopefully this helps someone out there. As I stated previously, this wasn't meant to bash anyone or Forge just wanted to create some awareness to others. There are plenty of people that run this product that have no issues.

Haw1es 12-07-2013 08:01 AM

Geese that's a big hole, seems like a quality control issue on forges end. Any manufacturer can have the occasional failure though. If that's not fixable, I would contact forge to see if they can help you out.

arewmors 12-07-2013 09:57 AM

Yup I already emailed Forge and the place I bought it from. Hopefully I hear back sometime next week. It will be interesting to see what will be done, if anything.

Haw1es 12-07-2013 10:30 AM

That's good, from the photos it clearly shows that the o-ring either failed or was installed incorrectly.I hope they help you out!

the RIOT act 12-07-2013 11:12 AM

Yeah that kinda stuff happens with anything aftermarket occasionally. I'm positive they'll help you out with a replacement. Don't lose faith in Forge though Andy. I've had mine on for a year and a half with no issues of any kind.


[color=gray]Sent from [url=http://www.autoguide.com/mobile]AutoGuide.com App[/url][/color]

pzr2874 12-07-2013 05:51 PM

That looks like a bad defect.

Forge will take care of you I'm sure.

Good catch though

BLAZE2099 12-08-2013 10:51 AM

I'll give ya ten bucks for it;)

arewmors 12-08-2013 10:54 AM

[quote=BLAZE2099;409578]I'll give ya ten bucks for it;)[/quote]

Fol. Will see Randy. It depends if they want it back for the warranty.

NeverSummer 12-08-2013 12:13 PM

[quote=arewmors;409586]Fol. Will see Randy. It depends if they want it back for the warranty.[/quote]

They will prob give you another once you send that one back. Then you can resell the new one


[color=gray]Sent from [url=http://www.autoguide.com/mobile]AutoGuide.com App[/url][/color]

Pakal13 01-05-2014 04:36 PM

Sorry for the bump, but wondering what the end result was.

I have the same in my '12 WRX for 4 or so months now, no issues at all and very happy with it; just curious if Forge resolved things to your liking or not?

Thanks -

arewmors 01-05-2014 06:33 PM

I contacted forge and they had me contact the company I purchased it from. I contacted the company and they were working with forge for a warranty, and the part to be sent straight back to forge. In the process I had the company send me a grimmspeed electronic boost control solenoid in place of the forge as I wanted one since I was going for a protune since it needs to be tuned for. The solenoid isn't as much as the bpv so I still should be getting some money back. I am currently awaiting information from the company. If I don't hear back soon, I will be contacting them to see the progress of the warranty.


[color=gray]Sent from [url=http://www.autoguide.com/mobile]AutoGuide.com Free App[/url][/color]

Pakal13 01-05-2014 07:58 PM

[quote=arewmors;420945]I contacted forge and they had me contact the company I purchased it from. I contacted the company and they were working with forge for a warranty, and the part to be sent straight back to forge. In the process I had the company send me a grimmspeed electronic boost control solenoid in place of the forge as I wanted one since I was going for a protune since it needs to be tuned for. The solenoid isn't as much as the bpv so I still should be getting some money back. I am currently awaiting information from the company. If I don't hear back soon, I will be contacting them to see the progress of the warranty.


[color=gray]Sent from [url=http://www.autoguide.com/mobile]AutoGuide.com Free App[/url][/color][/quote]

Thanks for the quick reply - good luck with, and enjoy the Grimmspeed EBCS and the protune!


All times are GMT -5. The time now is 07:49 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.