CEL light, blow through, info P0172, look out - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 10-07-2010, 05:54 PM
WRXtuners Member
 
synolimit's Avatar
 
Join Date: Aug 2009
Location: Ohio
Posts: 1,415
synolimit is a helpful contributing member
CEL light, blow through, info P0172, look out

so i just wanted to post this because i wasnt getting any good info here or nasico in searches. im blow through as most of you know. have been for 6 months maybe and car runs great, till now. ive had my first check engine light 3 times now. P0172 rich bank 1. ive reset the code and a week or two later it comes back on. always while driving normally. no boost, no hard throttle. just 10% maybe throttle, 35-65mph crusing.

a lot of people keep saying things like leaks and spark plugs and O2's and not really anything of value. so i got a print out from the dealer and the steps include

1. check exahust for leaks

2. check air leaks

3. check fuel pressure, could be clogged line, bent hose, improper fuel pump discharge

4. check engine coolant temp sensor

5. check MAF sensor

so that leaves out the spark plugs and O2's people have been buying and wasting time on. i believe subi would of added that in if they were the problems.

1. i do have an exhaust leak but small and at the DP to CBE. so that cant be it as the O2 sensor is in front of that. i will check UP and DP to turbo later but im pretty sure its all good.

2. i check my air system and FMIC hoses pretty often and its not likely they just leak. i will pressure test it though soon as most people will jump all over my TurboXS BOV.

3. fuel system is untouched besides 255 Walbro and pretty sure again all is well.

4. i dont have anyway of looking at coolent temp beside my stock gauge, so ill save it to the very end and again not likely.

5. i think this is it! because im blow through my MAF will see a lot thrown at it, more then if it was just behind the air filter.

things ive done. i have 2 catch cans and well they dont work 100%. there is no media in either so the first just collects water and blow by then vapor and crap blows into the second one, then it goes back to the intake were some blow by still goes. that means blow by can go through the turbo, FMIC and hit the MAF. this doesnt happen in stock form as the MAF is right behind the air filter. so what ive did last week was cap off the hose letting the oil go back to the inlet tube and put a little filter on the second catch can. i reset the CEL for the second time and today it came on again. So i checked the MAF sensor and it had some oily/ dust spots stuck to it. so i cleaned it with MAF cleaner and we'll see what we see.

so any guys that went blow through like me, check your MAF sensor and see if its dirty. you might have to clean it a lot more then just filter changes or cleans.

ill post back if it comes back on and if my lazy ass does a leak test. other than that ill be out of ideas !Cry!

Scott-2011 WRX 335HP 394TQ 93 VF52!
http://www.wrxtuners.com/forums/f121/2011-wrx-build-31226/
synolimit is offline  
Sponsored Links
Advertisement
 
#2 Old 10-08-2010, 08:26 AM
WRXtuners Member
 
Join Date: Sep 2009
Location: Michigan
Posts: 2,158
RcrsWetDream is known to be trustworthy and helpful RcrsWetDream is known to be trustworthy and helpful
I'll bet it's the MAF... Gets covered in gunk, so it can't read all the air that is coming through, so it gets more fuel than it should.

-Chris
RcrsWetDream is offline  
#3 Old 10-08-2010, 10:21 AM
WRXtuners Member
 
synolimit's Avatar
 
Join Date: Aug 2009
Location: Ohio
Posts: 1,415
synolimit is a helpful contributing member
Well I cleaned it so hope it's all good. I did notice my mileage wasn't great. Gauge was reading 24.5 and only about 310-330 miles I think. Filled up today with 14.5 gallons which is 21-22 mpg. I normally get 26-28mpg and high 300's.

Scott-2011 WRX 335HP 394TQ 93 VF52!
http://www.wrxtuners.com/forums/f121/2011-wrx-build-31226/
synolimit is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On