08 WRX boost spike question - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 03-12-2011, 07:11 PM Thread Starter
WRXtuners Member
 
Join Date: Mar 2011
Location: New Hampshire
Posts: 2
santacruz724 is an unknown
08 WRX boost spike question

Hey guys. Today i was slowly accelerating on the highway and i felt my car stutter and drop about 500 rpm and catch back up an instant after. I tried to re-enact the situation a few times and i couldnt do it. However, while i was playing around i noticed that if i fully accelerate in 4th or 5th gear starting at about 3k-3.5k rpms my car would over boost to about 22/23 psi(tuned to 19 psi). I got these readings on my accessport and on my boost gauge. I have a bigger tmic, intake, high flow downpipe, and catback installed. I also got my car pro tuned with all of these mods in place and my car has been running beautifully for the past year. I was wondering if anyone had any ideas on what could randomly start causing issues like this. I gave my boost hoses a quick once over but it was getting dark by the time i got home and i also tried cleaning my maf sensor. Thanks in advance!
santacruz724 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 03-12-2011, 09:08 PM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
Any CELs or codes?

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
post #3 of 4 Old 03-12-2011, 11:24 PM
WRXtuners Member
 
Join Date: Sep 2009
Location: Michigan
Posts: 2,158
RcrsWetDream is known to be trustworthy and helpful RcrsWetDream is known to be trustworthy and helpful
Cold weather can cause the car to overboost as the colder, more dense air = more air mass going through the turbo.

Your best bet is to get a 3-port ebcs and get tuned for that as well, it'll help eliminate boost spiking. If you add EWG boost spikes will be gone forever.

Also, it's really only in low rpm, high load situations like flooring it in 4th or 5th gear, so in the future just know the car doesn't like that and downshift.

-Chris
RcrsWetDream is offline  
post #4 of 4 Old 03-13-2011, 06:17 AM Thread Starter
WRXtuners Member
 
Join Date: Mar 2011
Location: New Hampshire
Posts: 2
santacruz724 is an unknown
Thanks for the quick responses. The car has no CEL or codes thrown and whats strange is the car wasn't doing anything funny in the colder weather. It was actually one of the warmest days of the winter yesterday. I reset my learned data and reloaded my AP map just to make sure and the problem still persisted. I will look into the ebcs or wastegate options for a bit more reliability i just find it strange that this randomly started occuring.
santacruz724 is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome