new from tallahassee - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 01-30-2008, 11:24 AM
WRXtuners Member
 
Join Date: Jan 2008
Location: Florida
Posts: 49
christommy is an unknown
Send a message via AIM to christommy
new from tallahassee

hey guys my names chris, im currently in the process of trading in my 01 v6 camaro for a 04 wrx. its got about 58k miles on it, some kind of aftermarket BOV that my buddy is gonna figure ### kind some time lol and a K&N intake on it so far.

so basically im here to learn bout the ins and outs of the motor and the car, i kno alot bout it already but id like to learn some more and join a good forum and community and possibly get a meet up wit some ppl in this area.

but i guess thats it for now, if u wanna kno anything else jus ask. ill get some pics once i get it.

peace chris
christommy is offline  
Sponsored Links
Advertisement
 
#2 Old 01-30-2008, 12:57 PM
WRXtuners Member
 
Longshot's Avatar
 
Join Date: Aug 2007
Location: Connecticut
Posts: 1,119
Images: 5
Longshot is a helpful contributing member
Send a message via AIM to Longshot
Welcome dude, FYI BOV's are not good for these cars unless they are protuned for them. Read the sticky about BOV's and CAI's on this site, as well as the other stickies to get started.

Mike
DTRacing Tuned
Longshot is offline  
#3 Old 01-30-2008, 02:41 PM
Moderator
 
mosc's Avatar
 
Join Date: Mar 2005
Location: Pennsylvania
Posts: 6,474
Images: 7
mosc is a helpful contributing member
Garage
Welcome! Watch out on the BOV, you can easily mess things up.

04 STi 16G powered lagless fun
04 WRX: SOLD
mosc is offline  
#4 Old 01-30-2008, 03:29 PM
WRXtuners Member
 
xmoniewrx's Avatar
 
Join Date: Mar 2007
Location: Illinois
Posts: 509
xmoniewrx is an unknown
Welcome to the forums !
xmoniewrx is offline  
#5 Old 01-30-2008, 10:25 PM
WRXtuners Member
 
Join Date: Jan 2008
Location: Florida
Posts: 49
christommy is an unknown
Send a message via AIM to christommy
dang i didnt kno all that about the BOV's.
i found out today that its a turbo xs, along wit that it has a K&N typhoon intake.
is it bad to run the car as it is for like a couple months, getting used to it?
cause imma be kinda broke for a while trying to peice together a exhaust set up.

i was thinking a borla muffler and then getting a shop to weld up some 3" piping
from the turbo back????
christommy is offline  
#6 Old 01-31-2008, 06:20 AM
WRXtuners Member
 
Longshot's Avatar
 
Join Date: Aug 2007
Location: Connecticut
Posts: 1,119
Images: 5
Longshot is a helpful contributing member
Send a message via AIM to Longshot
If money is tight check ERZ on ebay. Plenty of people have gone this route and it will probably be the cheapest.

Mike
DTRacing Tuned
Longshot is offline  
#7 Old 01-31-2008, 05:04 PM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
Welcome to the forums. Check out vendors and classifieds if money is tight and you are looking for parts. Just read as much as you can, there is alot to learn here on this site alone.

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
#8 Old 02-01-2008, 12:46 PM
WRXtuners Member
 
Join Date: Jan 2008
Location: Florida
Posts: 49
christommy is an unknown
Send a message via AIM to christommy
ok so i picked up my car today and i was driving it around and after about 30-45 mins the car started to sputter a lil bit while accelerating and then once at a parking pulling in in neutral it died on me. it also seems to be a lil intermittin b/c it dont do it all the time but a good majority of the time.

the only things done to the car are a K&N typhoon intake and turbo xs BOV which were on the car when i got it. it looks like it has an aftermarket downpipe too but im not sure.
christommy is offline  
#9 Old 02-01-2008, 01:03 PM
WRXtuners Member
 
Longshot's Avatar
 
Join Date: Aug 2007
Location: Connecticut
Posts: 1,119
Images: 5
Longshot is a helpful contributing member
Send a message via AIM to Longshot
It's your BOV and/or intake. Get rid of both and look for stock components. Once you get your stock setup back in reset the ECU and it should ride just fine. Probably more likely the BOV than the intake.

Mike
DTRacing Tuned
Longshot is offline  
#10 Old 02-01-2008, 01:11 PM
WRXtuners Member
 
Join Date: Jan 2008
Location: Florida
Posts: 49
christommy is an unknown
Send a message via AIM to christommy
lol sorry bout the other thread jus tryin to get alof of info on it.

i dont have either stock BOV or intake tho.
i work at the suby dealership here in town, is there anything they could do there as in tuning or anything?? they gonna look at it when i get up there once i told em bout it.
christommy is offline  
#11 Old 02-01-2008, 01:45 PM
WRXtuners Member
 
Longshot's Avatar
 
Join Date: Aug 2007
Location: Connecticut
Posts: 1,119
Images: 5
Longshot is a helpful contributing member
Send a message via AIM to Longshot
Find out if they have any of those stock components there. Otherwise check classifieds on nasioc, here, or just simply do a google search.

Mike
DTRacing Tuned
Longshot is offline  
#12 Old 02-01-2008, 09:17 PM
WRXtuners Member
 
Join Date: Jan 2008
Location: Florida
Posts: 49
christommy is an unknown
Send a message via AIM to christommy
so i jus checked some things under the hood after i got tired of dealing with the problem,
and i found out that the coupler leading to the intercooler had come loose and was leaking, so after fixing it it works fine now.

also while out there i noticed that my headers looked like after market ones and the DP looks after market too. If i got some pics of the headers, UP,and DP could someone tell me if they are aftermarket or not?
christommy is offline  
#13 Old 02-02-2008, 08:17 AM
WRXtuners Member
 
Longshot's Avatar
 
Join Date: Aug 2007
Location: Connecticut
Posts: 1,119
Images: 5
Longshot is a helpful contributing member
Send a message via AIM to Longshot
yes sir

Mike
DTRacing Tuned
Longshot is offline  
#14 Old 02-02-2008, 08:43 AM
WRXtuners Member
 
Join Date: Jan 2008
Location: Florida
Posts: 49
christommy is an unknown
Send a message via AIM to christommy
sweet thanks for all the help lol
i feel like the biggest newb evAR lmao
christommy is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On