Virgin at the strip. - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 13 Old 08-05-2005, 11:09 AM Thread Starter
WRXtuners Member
 
9d2TSi's Avatar
 
Join Date: Mar 2005
Location: Michigan
Posts: 3,171
Images: 5
9d2TSi is more helpful than not
Send a message via AIM to 9d2TSi Send a message via MSN to 9d2TSi
Virgin at the strip.

Hahaha, got your attention didn't it. Anyways, I'm taking her to the track tonight for the first time with a few STi buddies of mine. I've never been there as an actual participant. Just usually watching. I'll post a slip tonight when I get back. These RE92's are in trouble. I hope that the STi guys don't make me look too sick.


Wish me luck.

Later.

me.

My car is well, it's like 10 lbs of shit in a 5 lb bag...

<------ Click to see what I'm workin' with. ;)
9d2TSi is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 08-05-2005, 11:18 AM
WRXtuners Member
 
Jave's Avatar
 
Join Date: Nov 2004
Location: Oklahoma
Posts: 1,577
Images: 6
Jave is more helpful than not
good luck and have fun...
Jave is offline  
post #3 of 13 Old 08-05-2005, 11:22 AM
WRXtuners Member
 
panasyncp17's Avatar
 
Join Date: Mar 2005
Location: Connecticut
Posts: 462
Images: 9
panasyncp17 is an unknown
Send a message via AIM to panasyncp17
Good luck
panasyncp17 is offline  
post #4 of 13 Old 08-06-2005, 03:05 AM Thread Starter
WRXtuners Member
 
9d2TSi's Avatar
 
Join Date: Mar 2005
Location: Michigan
Posts: 3,171
Images: 5
9d2TSi is more helpful than not
Send a message via AIM to 9d2TSi Send a message via MSN to 9d2TSi
[B]What a riot!!!![/B]

That was the most fun that I've had with my car yet. I did get my booty waxed by some badazzed rides though, but all in all, it was a very cool experience. I made 8 passes total, allowing for some cool down between each one. I did however, beat a pretty sweet Stang and a very janky Escort with an equally nasty bodykit/gaudy wing. He was running solid 19's all night. My beatings came from a Buick GN, a Z06, 2 Camaros, and The STi's that I came with.

1. 15.01 @ 95.93 2.70 60ft.
2. 14.53 @ 94.25 2.09 60ft. Better, but still
3. 13.98 @ 95.50 1.95 60 ft. Best run of the night. Not awesome, but not totally
Runs 4-8 were low to mid 14's, not very proud of that, but not too bad either for a newb.

I really need to get my 60's down, then the better times will come. I really wanted to leave with a 13.5 run, but since my good friend was running that and better, I didn't see it happening for me yet. He also has an STi with AP/Street tuner though. His best was a 13.21 @102. He kept roasting them off though. I'll try and take pics of my slips, but my digicam sucks bawls. We'll see what happens.

Later.

My car is well, it's like 10 lbs of shit in a 5 lb bag...

<------ Click to see what I'm workin' with. ;)
9d2TSi is offline  
post #5 of 13 Old 08-06-2005, 03:44 AM
WRXtuners Member
 
panasyncp17's Avatar
 
Join Date: Mar 2005
Location: Connecticut
Posts: 462
Images: 9
panasyncp17 is an unknown
Send a message via AIM to panasyncp17
Not bad for first time I guess. What were your 60's?
panasyncp17 is offline  
post #6 of 13 Old 08-06-2005, 03:59 AM Thread Starter
WRXtuners Member
 
9d2TSi's Avatar
 
Join Date: Mar 2005
Location: Michigan
Posts: 3,171
Images: 5
9d2TSi is more helpful than not
Send a message via AIM to 9d2TSi Send a message via MSN to 9d2TSi
My 60's were awful, they ranged from 1.95 (best) to 2.70 (worst).

They averaged 2.195. This needs work bad. If I can get them down to 1.8 or less, I can get some decent times.

My car is well, it's like 10 lbs of shit in a 5 lb bag...

<------ Click to see what I'm workin' with. ;)
9d2TSi is offline  
post #7 of 13 Old 08-06-2005, 04:49 AM
WRXtuners Member
 
panasyncp17's Avatar
 
Join Date: Mar 2005
Location: Connecticut
Posts: 462
Images: 9
panasyncp17 is an unknown
Send a message via AIM to panasyncp17
A 1.8 60' will definetly bring your ET's down. 2.7... Did you start in second gear by mistake?
panasyncp17 is offline  
post #8 of 13 Old 08-06-2005, 11:40 AM Thread Starter
WRXtuners Member
 
9d2TSi's Avatar
 
Join Date: Mar 2005
Location: Michigan
Posts: 3,171
Images: 5
9d2TSi is more helpful than not
Send a message via AIM to 9d2TSi Send a message via MSN to 9d2TSi
Hahaha, no, but you'd sure think so. I've read a few things about launching your WRX that I never really thought about. I'll try what I read and see if that makes a diff.

The 2.7, I almost stalled it, it wasn't pretty.

My car is well, it's like 10 lbs of shit in a 5 lb bag...

<------ Click to see what I'm workin' with. ;)
9d2TSi is offline  
post #9 of 13 Old 08-06-2005, 09:19 PM
WRXtuners Member
 
panasyncp17's Avatar
 
Join Date: Mar 2005
Location: Connecticut
Posts: 462
Images: 9
panasyncp17 is an unknown
Send a message via AIM to panasyncp17
Yea I'm not to good at launching myself, I'll either bog or you smell some nice burning clutch for like 5 minutes
panasyncp17 is offline  
post #10 of 13 Old 08-09-2005, 09:54 AM
WRXtuners Member
 
leewmlds's Avatar
 
Join Date: Oct 2004
Location: Virginia
Posts: 100
Images: 16
leewmlds is an unknown
nice runs.

my first time out i ran a best of 15.63 @ 90 out of 4 runs
six months later i ran a best of 14.63 @ 92 out of 6 runs.
leewmlds is offline  
post #11 of 13 Old 08-09-2005, 11:53 AM
WRXtuners Member
 
Lost One's Avatar
 
Join Date: Jul 2005
Location: Indiana
Posts: 48
Images: 3
Lost One is an unknown
Nice runs!

Noticed on the pics of your car your gauges, is that the Autometer bezel mount? I'm thinking of getting that, too. Do you like it? Was it hard to install or run the wiring?
Lost One is offline  
post #12 of 13 Old 08-09-2005, 12:03 PM Thread Starter
WRXtuners Member
 
9d2TSi's Avatar
 
Join Date: Mar 2005
Location: Michigan
Posts: 3,171
Images: 5
9d2TSi is more helpful than not
Send a message via AIM to 9d2TSi Send a message via MSN to 9d2TSi
Quote:
Originally Posted by Lost One
Nice runs!

Noticed on the pics of your car your gauges, is that the Autometer bezel mount? I'm thinking of getting that, too. Do you like it? Was it hard to install or run the wiring?
Thanks bro. Yes that's the AutoMeter one. It fits well and looks nice, but I hate it's design. You have 2 screw holes in the bottom part of it with no reinforcement behind them. If you tighten them down too tight the screw will just go through it. If I had it to do over again, I would've gotten the clock/dash bezel. I like them by the steering wheel though, less likely to draw attention like the A pillar ones. As far as wiring, it's a pita whichever way you do it. I hate wiring. You can do it though, it's not all that bad. I'm just lazy.

All in all, it's pretty easy to install.

My car is well, it's like 10 lbs of shit in a 5 lb bag...

<------ Click to see what I'm workin' with. ;)
9d2TSi is offline  
post #13 of 13 Old 08-09-2005, 10:49 PM
WRXtuners Member
 
imbeterthanu's Avatar
 
Join Date: Oct 2004
Location: Florida
Posts: 975
Images: 4
imbeterthanu is an unknown
Send a message via AIM to imbeterthanu
thats not too bad. i ran stock 14.5 with a 2 sec 60 foot time. the track down here s very very slick. so its hard even with all wheel drive to pull a good 60foot time. i just installed my down/uppipe and i will be going back in a like a month.
imbeterthanu is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome