Sac Raceway/ time slip/ launch.... - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 09-05-2006, 09:05 PM Thread Starter
WRXtuners Member
 
Join Date: Sep 2006
Location: California
Posts: 14
BigBLuE03 is an unknown
Sac Raceway/ time slip/ launch....

ok guy i just got back from Strip a few days ago. and i thought i did pretty good. i think. I have a 2003 Wrx. Im running Cobb Stage 1 HWG. My back tires tread is very low... Tires psi was all at 45 psi. Temperature was mid-upper 80's

I got more times but this was my fastest time... 60ft did not show up for some reason

time slip:

RT: .721
I1: .000
I2: 5.959
I3: 9.157
mph(I3) 76.513
I4: 11.877
E.T. 14.216
mph 96.484

My 60ft time was around 2.3 and 2.2 all the runs i did. I cudn't hit below 2.0... sigh
So is this normal? or shud i be faster? i am only stg1? wut do u guys think, and how to improve my launch time.
BigBLuE03 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 09-05-2006, 09:10 PM
WRXtuners Member
 
WRXtreme's Avatar
 
Join Date: Mar 2003
Location: Pennsylvania
Posts: 1,654
WRXtreme is more helpful than not
Send a message via AIM to WRXtreme
Thats seems like a decent run for Stage 1. If you would get those '60 times sub 2sec you would be well into the 13s, which isn't bad at all. Good run!
WRXtreme is offline  
post #3 of 7 Old 09-05-2006, 09:13 PM
WRXtuners Member
 
mxboy15u's Avatar
 
Join Date: Oct 2005
Location: North Carolina
Posts: 1,470
mxboy15u is an unknown
That seems really good for stage 1!! Get those 60 foots down, and you will be running better than most (including me) with just stage 1.
mxboy15u is offline  
post #4 of 7 Old 09-05-2006, 09:24 PM Thread Starter
WRXtuners Member
 
Join Date: Sep 2006
Location: California
Posts: 14
BigBLuE03 is an unknown
yeah ive been workin on my launch so much its like i dunno, u think if i get better tires my 60 ft times wud improve? right now im looking at my 60 ft time and it says: 2.302, 2.218, 2.203, 2.348, 2.253, 2.249. all those time r with me feathering and rev matching the rpms. then other s i just slipped it really fast. so dont really know how to improve my launch... :sigh:
BigBLuE03 is offline  
post #5 of 7 Old 09-06-2006, 07:30 PM
WRXtuners Member
 
WRXtreme's Avatar
 
Join Date: Mar 2003
Location: Pennsylvania
Posts: 1,654
WRXtreme is more helpful than not
Send a message via AIM to WRXtreme
Better tires are really going to help until you start getting excessive amounts of wheel spin. What I do to launch is rev from 4-5k, then slip the clutch out in less then a second, but don't just drop it. The revs will fall a little but they wouldn't fall out of the powerband. You can be aggressive with the clutch, just don't side step it or drop it, thats really hard on your drivetrain.
WRXtreme is offline  
post #6 of 7 Old 09-06-2006, 09:41 PM
WRXtuners Member
 
ohhNOwrx's Avatar
 
Join Date: Jan 2006
Location: Iowa
Posts: 242
ohhNOwrx is an unknown
My first run on the track i missed 2nd gear and did 14.6 and after 6 runs i ended up with 13.7 for my best time and this was also with stage 1 and crazy 6k launches.
ohhNOwrx is offline  
post #7 of 7 Old 09-07-2006, 10:14 PM
WRXtuners Member
 
car_doper's Avatar
 
Join Date: Aug 2006
Location: Texas
Posts: 95
Images: 13
car_doper is an unknown
That sounds like a good run to me. Congrats
car_doper is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On