First Dragstrip Running With My Rex!!! - Subaru WRX Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 20 Old 05-27-2006, 08:53 PM Thread Starter
WRXtuners Member
 
AOD_SNOWMAN's Avatar
 
Join Date: Jan 2006
Location: Colorado
Posts: 90
AOD_SNOWMAN is an unknown
Send a message via MSN to AOD_SNOWMAN
First Dragstrip Running With My Rex!!!

Just thought I would enlighten you all about my fun filled night last night! I drove down to Pueblo Colorado to the Pueblo Motorsports Park drag strip to get an Idea of what my car would run before I started modding it and heres how she went.

I ran a total of 7 times but here is my best timeslip:
4900FT ABSL
Non-compound
Completely Stock 04 WRX

LEFT LANE
http://i43.photobucket.com/albums/e3...OWMAN/scan.jpg

R/T- .055
60FT- 2.147
330FT- 6.413
1/8- 9.930
1000FT- 12.946
1/4- 15.485
MPH- 88.39

Sure as hell was fun I can't wait to get some money so I can get better times!!!!!
AOD_SNOWMAN is offline  
Sponsored Links
Advertisement
 
post #2 of 20 Old 05-27-2006, 09:08 PM
WRXtuners Member
 
9d2TSi's Avatar
 
Join Date: Mar 2005
Location: Michigan
Posts: 3,171
Images: 5
9d2TSi is more helpful than not
Send a message via AIM to 9d2TSi Send a message via MSN to 9d2TSi
Awesome man. Get that 60ft time down some and you'll be in good shape.

My car is well, it's like 10 lbs of shit in a 5 lb bag...

<------ Click to see what I'm workin' with. ;)
9d2TSi is offline  
post #3 of 20 Old 05-28-2006, 12:39 AM Thread Starter
WRXtuners Member
 
AOD_SNOWMAN's Avatar
 
Join Date: Jan 2006
Location: Colorado
Posts: 90
AOD_SNOWMAN is an unknown
Send a message via MSN to AOD_SNOWMAN
Hell I was spinning alittle bit, I know that had affect on my 60' being that it wasn't on compound and only on asphalt. What would you say is the best launch method. I tried clutch slip method and I dropped a few times:eek: , thats how I got my 2.1!!!!
AOD_SNOWMAN is offline  
post #4 of 20 Old 05-28-2006, 11:44 AM
WRXtuners Member
 
imbeterthanu's Avatar
 
Join Date: Oct 2004
Location: Florida
Posts: 975
Images: 4
imbeterthanu is an unknown
Send a message via AIM to imbeterthanu
right before you launch. have the clutch right before the friction point. then light drops let of the clutch.

▼SbiΣ Mi▼
mike
imbeterthanu is offline  
post #5 of 20 Old 05-28-2006, 12:57 PM Thread Starter
WRXtuners Member
 
AOD_SNOWMAN's Avatar
 
Join Date: Jan 2006
Location: Colorado
Posts: 90
AOD_SNOWMAN is an unknown
Send a message via MSN to AOD_SNOWMAN
Tried that too...I think I just need more runs to get it down!!!!
AOD_SNOWMAN is offline  
post #6 of 20 Old 05-28-2006, 09:00 PM
WRXtuners Member
 
9d2TSi's Avatar
 
Join Date: Mar 2005
Location: Michigan
Posts: 3,171
Images: 5
9d2TSi is more helpful than not
Send a message via AIM to 9d2TSi Send a message via MSN to 9d2TSi
What is your launch rpm that you're using? You're best off doing what Mike said above, I can attest to that personally. The time that I didn't do that, I had a bunch of teeth missing in my tranny.

The cool thing is, when I go back to the track, my launch control is set to 4500. So, hopefully I won't do that again.

My car is well, it's like 10 lbs of shit in a 5 lb bag...

<------ Click to see what I'm workin' with. ;)
9d2TSi is offline  
post #7 of 20 Old 06-01-2006, 11:57 AM
WRXtuners Member
 
JiveMasterT's Avatar
 
Join Date: Jan 2006
Location: New York
Posts: 677
Images: 5
JiveMasterT is more helpful than not
Whoa... only a 15.4? Should have been down in the low 14s. Let air out of your tires next time to get your launch down. You should have like a 1.9-1.8 60' time. It also seems like you're letting off the gas too soon... your ET MPH is way down. Not bad for a first time at the track though! I was somewhere around the same my first time. 2nd Time, I burried my car in mid 14s with the exact same mods as the first time I went.

Patrick - 2007 STi Limited
▼SbiΣ Mi▼

Last edited by JiveMasterT; 06-01-2006 at 03:57 PM.
JiveMasterT is offline  
post #8 of 20 Old 06-01-2006, 02:34 PM
WRXtuners Member
 
trek98xc's Avatar
 
Join Date: May 2005
Location: Illinois
Posts: 706
trek98xc is an unknown
Send a message via AIM to trek98xc
Practice makes perfect... well... there is no perfect in drag racing. Youll get a lot better though

rob
▼SbiΣ Mi▼
trek98xc is offline  
post #9 of 20 Old 06-01-2006, 11:40 PM Thread Starter
WRXtuners Member
 
AOD_SNOWMAN's Avatar
 
Join Date: Jan 2006
Location: Colorado
Posts: 90
AOD_SNOWMAN is an unknown
Send a message via MSN to AOD_SNOWMAN
Jive masterT you gotta remember I was running at nearly 5000feet above sea level!!!! I can't get low 14's factory. And yes I haven't got my launching and 60ft times where they should be. But I'm going back to the track tomorrow and I'll get some more practice in!!!! Also i was on the gas all they way through the traps!!!!
AOD_SNOWMAN is offline  
post #10 of 20 Old 06-01-2006, 11:53 PM
WRXtuners Member
 
JiveMasterT's Avatar
 
Join Date: Jan 2006
Location: New York
Posts: 677
Images: 5
JiveMasterT is more helpful than not
Quote:
Originally Posted by AOD_SNOWMAN
Jive masterT you gotta remember I was running at nearly 5000feet above sea level!!!! I can't get low 14's factory. And yes I haven't got my launching and 60ft times where they should be. But I'm going back to the track tomorrow and I'll get some more practice in!!!! Also i was on the gas all they way through the traps!!!!
Didn't realize you were at 5k above sea level... I hope you get your 60' times down... try to get into like 1.9 or so and you should be into high 14s, I think.

Patrick - 2007 STi Limited
▼SbiΣ Mi▼
JiveMasterT is offline  
post #11 of 20 Old 06-03-2006, 03:16 AM Thread Starter
WRXtuners Member
 
AOD_SNOWMAN's Avatar
 
Join Date: Jan 2006
Location: Colorado
Posts: 90
AOD_SNOWMAN is an unknown
Send a message via MSN to AOD_SNOWMAN
Ok I ran again tonight!!! But I could not get below a 2.1 60ft, and couldn't top the 88mph mark or the 15.4 1/4 time!!!! But I'm getting a better feel for the car! I noticed that my fronts are spinning quite a bit. BTW I'm running the FUSION HRI stock sized tires. I was thinking maybe some stickier ones might help. But I'd rather spend the money on my Stage 4 dream!!!!
AOD_SNOWMAN is offline  
post #12 of 20 Old 06-03-2006, 07:32 AM
WRXtuners Member
 
nick4592's Avatar
 
Join Date: Sep 2005
Location: Colorado
Posts: 1,030
Images: 9
nick4592 is more helpful than not
Send a message via AIM to nick4592 Send a message via MSN to nick4592 Send a message via Yahoo to nick4592
remember what Altitude you are at also....we run almost a full second "slower" here than on sea level...your times aren't too bad for a stock wrx...keep practicing and we'll get those times down

"Life's a bowl of punch so go ahead and Spike it!" -311
nick4592 is offline  
post #13 of 20 Old 06-03-2006, 11:42 AM Thread Starter
WRXtuners Member
 
AOD_SNOWMAN's Avatar
 
Join Date: Jan 2006
Location: Colorado
Posts: 90
AOD_SNOWMAN is an unknown
Send a message via MSN to AOD_SNOWMAN
mainly I'm just wanting to get my 60ft times better, my reactions are great, but like I said I'm still spinning alittle bit off the line!!!
AOD_SNOWMAN is offline  
post #14 of 20 Old 06-03-2006, 11:47 AM
WRXtuners Member
 
JiveMasterT's Avatar
 
Join Date: Jan 2006
Location: New York
Posts: 677
Images: 5
JiveMasterT is more helpful than not
:eek:
Quote:
Originally Posted by AOD_SNOWMAN
mainly I'm just wanting to get my 60ft times better, my reactions are great, but like I said I'm still spinning alittle bit off the line!!!
I'm willing to bet that letting some air out of your tires or getting a stickier set of tires will cut that down for you quite a bit.

What rpm are you launching at? I can tell you're not dumping your clutch, and your tranny loves you for that.

Patrick - 2007 STi Limited
▼SbiΣ Mi▼
JiveMasterT is offline  
post #15 of 20 Old 06-03-2006, 02:28 PM
WRXpert
 
bigbadbuddha's Avatar
 
Join Date: Jan 2005
Location: Ontario, Canada
Posts: 1,747
Images: 15
bigbadbuddha is more helpful than not
Send a message via AIM to bigbadbuddha Send a message via MSN to bigbadbuddha
Good job man... Speed is an addicitve drug.... always want more.

Big Jae -
JDM version 7 bugeye
bigbadbuddha is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On