Curious Question - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 08-18-2006, 01:07 PM Thread Starter
WRXtuners Member
 
Join Date: Jan 2006
Location: New Jersey
Posts: 104
Images: 2
Mad Mordigan is an unknown
Curious Question

What should a 04 WRX run in the 1/4 mile that has full exhaust (no up-pipe), and a MBC? I'm just curious to see what you guys think.
Mad Mordigan is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 08-18-2006, 01:40 PM
WRXtuners Member
 
mxboy15u's Avatar
 
Join Date: Oct 2005
Location: North Carolina
Posts: 1,470
mxboy15u is an unknown
No up-pipe should be running around 20 seconds in the quarter.
Seriously though, I would say high 13s. Then your car would blow up. MBC is bad, read the faq.
mxboy15u is offline  
post #3 of 6 Old 08-18-2006, 01:57 PM
WRXtuners Member
 
Join Date: Jul 2006
Location: Pennsylvania
Posts: 21
Images: 2
wrx.evokllr is an unknown
yeah MBCs are bad news to begin with let alone having one without replacing the up-pipe read this Boost Controllers and You...
wrx.evokllr is offline  
post #4 of 6 Old 08-18-2006, 01:58 PM
WRXtuners Member
 
Join Date: Jul 2006
Location: Pennsylvania
Posts: 21
Images: 2
wrx.evokllr is an unknown
oh im sorry you did replace the uppipe
wrx.evokllr is offline  
post #5 of 6 Old 08-18-2006, 04:20 PM
WRXtuners Member
 
9d2TSi's Avatar
 
Join Date: Mar 2005
Location: Michigan
Posts: 3,171
Images: 5
9d2TSi is more helpful than not
Send a message via AIM to 9d2TSi Send a message via MSN to 9d2TSi
Take it to the strip and find out.

It's really hard to say how quick it is. Without tuning and just cranking the boost up, you're probably going to be knocking/pulling timing. This is very bad for power production, and even worse for engine longevity.

FWIW, my time was with just a turboback, uppipe and a K&N short ram. My 60 ft sucked, and I could've driven alot better. If that helps you at all.

My car is well, it's like 10 lbs of shit in a 5 lb bag...

<------ Click to see what I'm workin' with. ;)
9d2TSi is offline  
post #6 of 6 Old 08-18-2006, 06:51 PM Thread Starter
WRXtuners Member
 
Join Date: Jan 2006
Location: New Jersey
Posts: 104
Images: 2
Mad Mordigan is an unknown
i havent got around to putting it in yet. im going to try and do it tomorrow. i have a walboro fuel pump also. I ran a 14.01 with a 1.95 60 ft. im going to get a reflash and get it dyno-tuned in acouple weeks

Last edited by Mad Mordigan; 08-19-2006 at 05:57 PM.
Mad Mordigan is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome