Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Cylinder Head & Short Block (http://www.wrxtuners.com/forums/f103/)
-   -   Need Help with a vacuum leak (http://www.wrxtuners.com/forums/f103/need-help-vacuum-leak-28726/)

Bboy LiMiT 05-04-2010 08:33 PM

Need Help with a vacuum leak
 
I recently had my engine idling very hard. After going to advance auto parts (aap) and got my CEL's checked. After I went and consulted a Subaru mechanic I learned that the codes I was getting (PO171 x2) were telling me that I had a vacuum leak, and that it was somwhere between the MAF (which I think is right there on the on the air filter casing, please correct me if im wrong) and the heads... Which leaves a lot of piping. How would I go about checking where it is? I have no idea what to do so any help would be very helpful.

turmic 05-04-2010 10:06 PM

Normally spraying something like brake cleaner around the pipes and listening to hear the engine speed up or change. That should help you narrow down where the leak is.

Bboy LiMiT 05-05-2010 12:33 PM

Ok, and you do the pipes one at a time? Why is it that the engine will speed up? Does it have to be brake cleaner?

turmic 05-06-2010 09:32 PM

Anything alcohol related such as carb cleaner/brake cleaner. Something like that and yeah. One pipe or connection at a time would be the best idea. Spray one area and move on. Preferably a small area.

Bboy LiMiT 05-10-2010 06:51 PM

Thanks turmic. I sprayed a whole can of carb cleaner on all the pipes and it didn't rev up at all... The people at O'reilys said they think its the MAF sensor, is there anything else that it could be? I went up to the stealership and they said it would be 299.34 for a new one... I cant afford to go around just buying parts like that lol. Where should I go from here? My next url is gonna be ebay to see if i can find one on there.

turmic 05-11-2010 10:13 PM

O'Reilys doesn't have some MAF cleaner? You could just clean it and see if that helps.

Bboy LiMiT 05-12-2010 11:59 AM

That would be SWEET, I'll go check that out, what part do i need to clean? That little doughnut hole looking piece? The cheapest sensor I could find was $80! When i went to the stealership they quoted me $299.34... Is there anything else that it could be? I don't wanna be focusing on one thing just because someone said its probably the MAF, and that not even be it...I dont know what else it would be tho. What about the TPS, what happens when that goes out?

Bboy LiMiT 05-13-2010 09:05 PM

Ok so i got some MAF cleaner and it cleaned the mess out of it :D. Now it runs a LOT smoother and idles a lot nicer. When I get on it now there is a whirring sound and then the computer turns the turbo off and then it whirrs again. During the whirring you can tell an increase of power. So what im thinking is happening is the recirc spring is worn out. The air escapes so you dont hear any compressor surge (or so i think thats the reason). Is this reasonable or am I just being cheap? It does idle really nicely now, but how can you re...spring? the recirc spring? I heard something about a hammer? lol

djc1827 05-15-2010 07:08 PM

Maf was prob just wet

Bboy LiMiT 06-09-2010 09:13 AM

FINALLY got it figured out! The recirculator to intercooler gasket was bad... Now she's boosting but it turns off for some reason? When I took her to the dealership they said that it was throwing a code for no cats and an egt fail. When they looked at it they saw that it said 392 no matter how hot the egts were, even if you unplugged the sensor. Could it be cutting the turbo out because of this? Even more importantly, does anybody know why this was done and how i can fix it?

wagonracer 06-09-2010 10:37 AM

I can't remember the resistor value off the top of my head, but I use a radio shack resistor to manipulate the EGT value to the computer. You just unplug the sensor from the UP and insert the resistor. I've run that way for years with a catless UP. Sorry to not have the details, give it a search


All times are GMT -5. The time now is 09:22 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.