EJ20/EJ25 gone bad?? - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 12-02-2008, 02:22 PM
WRXtuners Member
 
Join Date: Dec 2008
Location: Florida
Posts: 2
prophecy1320 is an unknown
EJ20/EJ25 gone bad??

Ok the car is a 2002 wrx.

Mods
- 3" turboback- Injen Intake
- Turbo XS dual boost controller 15psi-20psi
- Upgraded top mount, HKS SSQ
- Ecu flashed for 2.0 setup.

- a bunch other mods for handling, undercarrage cusco brace, enkies rpf1's, control arms, strut bars, brace bars ect.

The car was practically stock internally until the car overheated and cracked the cylinder head. The then went to the dealer since Iam good friends with a service advisor there and he gave me a good deal on the rebuild.

He talked me into doing a 2.5 sti block since he has one lying around in a crate so I went with it and got it rebuilt. new stock 2.0 heads (with old valvetrain) and a EJ25 sti block, new crank, pistons and rods. We went with new oil pump, water pump and tensioners. Oem sti gasket kit.

So the car was driven for about 1000 miles on low boost for break in without ever passing 3k rpm. One night I decide to get on it on High boost, did a 1-3rd gear pull and the ROD bearing spins and I get rod knock. I send the car back to the dealer and they fix it with new crank and rods and said that I was due to driving.

I get the car back the second time and wait for 1000miles again on break in, Iam hesitant to even drive the car hard so I do a low boost pull to about 7k in 2nd-3rd gear and everything seemed fine. The next day I might have gotten to comfterable and tried it again on high boost and the same crap again, rod bearing decides to spin, the KNOCK CAME FROM THE SAME SIDE OF THE ENGINE when the last bearing was spun (passenger side by the turbo).

Well I get the car back for the 3rd time bieng warned that next time it happens a 2.0 will be going back in and its the end of my warrenty. The car has been drivin this car for about 1700 miles already and The car hasnt been revd past 4k.

Will the tune affect the setup like that? I figured a bad tune would probably take out a piston before it spun a rod. I always thought spun rod bearing were related to lack of oil pressure or lubrication on that specific rod journal.

Any input? I want to get the car flashed but Iam scared to even put it on the dyno.
prophecy1320 is offline  
Sponsored Links
Advertisement
 
#2 Old 12-05-2008, 05:55 AM
WRXtuners Member
 
Kjott21's Avatar
 
Join Date: May 2006
Location: Pennsylvania
Posts: 763
Kjott21 is known to be trustworthy and helpful Kjott21 is known to be trustworthy and helpful Kjott21 is known to be trustworthy and helpful
Garage
Quote:
Originally Posted by prophecy1320 View Post
Ok the car is a 2002 wrx.

Mods
- 3" turboback- Injen Intake
- Turbo XS dual boost controller 15psi-20psi
- Upgraded top mount, HKS SSQ
- Ecu flashed for 2.0 setup.

- a bunch other mods for handling, undercarrage cusco brace, enkies rpf1's, control arms, strut bars, brace bars ect.

The car was practically stock internally until the car overheated and cracked the cylinder head. The then went to the dealer since Iam good friends with a service advisor there and he gave me a good deal on the rebuild.

He talked me into doing a 2.5 sti block since he has one lying around in a crate so I went with it and got it rebuilt. new stock 2.0 heads (with old valvetrain) and a EJ25 sti block, new crank, pistons and rods. We went with new oil pump, water pump and tensioners. Oem sti gasket kit.

So the car was driven for about 1000 miles on low boost for break in without ever passing 3k rpm. One night I decide to get on it on High boost, did a 1-3rd gear pull and the ROD bearing spins and I get rod knock. I send the car back to the dealer and they fix it with new crank and rods and said that I was due to driving.

I get the car back the second time and wait for 1000miles again on break in, Iam hesitant to even drive the car hard so I do a low boost pull to about 7k in 2nd-3rd gear and everything seemed fine. The next day I might have gotten to comfterable and tried it again on high boost and the same crap again, rod bearing decides to spin, the KNOCK CAME FROM THE SAME SIDE OF THE ENGINE when the last bearing was spun (passenger side by the turbo).

Well I get the car back for the 3rd time bieng warned that next time it happens a 2.0 will be going back in and its the end of my warrenty. The car has been drivin this car for about 1700 miles already and The car hasnt been revd past 4k.

Will the tune affect the setup like that? I figured a bad tune would probably take out a piston before it spun a rod. I always thought spun rod bearing were related to lack of oil pressure or lubrication on that specific rod journal.

Any input? I want to get the car flashed but Iam scared to even put it on the dyno.
The tune will definitely affect the motor. With the 2.5L motor with 2.0L heads it raises the compression ratio and makes you more prone to knock and detonation. Please go and get a tune. MBC without a tune is a stupid mod. Do not boost the car till you get a tune.

My name is Ken and I am a HP Junkie.
Kjott21 is offline  
#3 Old 12-05-2008, 03:28 PM
WRXpert
 
LiL Shoaf's Avatar
 
Join Date: Jun 2005
Location: Pennsylvania
Posts: 1,810
Images: 2
LiL Shoaf is more helpful than not
Send a message via AIM to LiL Shoaf Send a message via Yahoo to LiL Shoaf
Ken is right. Unless your setup was built with a thicker head gasket your compression ratio was increased which is not desired for turbo charged cars.. This extra pressure can cause may issues..

02 WRX.. "It's fun when it runs.. Problem is that it hardly ever does..."
LiL Shoaf is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On