05 wrx no compression. - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 12-27-2014, 12:57 AM Thread Starter
WRXtuners Member
 
Join Date: Dec 2014
Posts: 3
Josh Sharp is an unknown
05 wrx no compression.

hello, im having a huge issue with my 05 subaru wrx hybrid swap. i was having some valve issues so i bought brian crower valves timing belt new gaskets the works. installed everything and went to start it nothing.. just a whine i tried doing a compression test and every cylinder has 0 psi! 0! it wont even move if i tried to crank it nothing is hitting im so lost on this ive never seen anything like it in my life. quick responsed need help thanks everyone!
Josh Sharp is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 12-31-2014, 06:14 PM
WRXtuners Member
 
fastwayracing's Avatar
 
Join Date: Dec 2014
Posts: 1
fastwayracing is an unknown
Recheck your timing marks.. When you did the head swap did you check the valve clearances?
fastwayracing is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome